Laravel Composer提示the requested PHP extension xxx is missing from your system.错误的解决办法

07-01 11:40   原创 26 责编:寂静的神经

在使用composer更新laravel的依赖时,遇到错误:

phpoffice/phpspreadsheet 1.14.0 requires ext-fileinfo * -> 
the requested PHP extension fileinfo is missing from your system.

错误信息的重点在后半句,意思是我的系统没有开启php fileinfo扩展。

我使用的是宝塔面板,开始php fileinfo扩展很方便,具体步骤如下:

在“软件商店”中找到要开启扩展的php版本,然后点击“设置”,在打开的窗口中选择“安装扩展”,然后找到“fileinfo”,点击“安装”即可,安装成功后,重启一下php就不会再提示错误了。

分享给小伙伴们:

最新文章

最热文章

零五科技,分享IT知识,国内顶级IT知识门户网站。

©2015 零五科技 版权所有